What’s Vulnerable › Vulnerabilities
CVE-2021-22548: Arbitrary enclave memory overread vulnerability in Asylo TrustedPrimitives::UntrustedCall
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-08 · updated 2026-06-17
- Weakness: CWE-788
Description
An attacker can change the pointer to untrusted memory to point to trusted memory region which causes copying trusted memory to trusted memory, if the latter is later copied out, it allows for reading of memory regions from the trusted region. It is recommended to update past 0.6.2 or git commit https://github.com/google/asylo/commit/53ed5d8fd8118ced1466e509606dd2f473707a5c
Affected products
- Google LLC Asylo: before 0.6.2 — fixed in 0.6.2
How to fix
Upgrade to a fixed version: Google LLC Asylo 0.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/google/asylo/commit/53ed5d8fd8118ced1466e509606dd2f473707a5c
- https://github.com/google/asylo/commit/53ed5d8fd8118ced1466e509606dd2f473707a5c
Get alerted when CVE-2021-22548 or the next vulnerability affects your stack