What’s Vulnerable › Vulnerabilities
CVE-2021-22550: Enclave memory overwrite/overread vulnerability in Asylo UntrustedCacheMalloc::GetBuffer
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-08 · updated 2026-06-17
- Weakness: CWE-823
Description
An attacker can modify the pointers in enclave memory to overwrite arbitrary memory addresses within the secure enclave. It is recommended to update past 0.6.3 or git commit https://github.com/google/asylo/commit/a47ef55db2337d29de19c50cd29b0deb2871d31c
Affected products
- Google LLC Asylo: before 0.6.3 — fixed in 0.6.3
How to fix
Upgrade to a fixed version: Google LLC Asylo 0.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/google/asylo/commit/a47ef55db2337d29de19c50cd29b0deb2871d31c
- https://github.com/google/asylo/commit/a47ef55db2337d29de19c50cd29b0deb2871d31c
Get alerted when CVE-2021-22550 or the next vulnerability affects your stack