What’s Vulnerable › Vulnerabilities
CVE-2021-22553: Heap Memory exhaustion in Gerrit
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-17 · updated 2026-06-17
- Weakness: CWE-400
Description
Any git operation is passed through Jetty and a session is created. No expiry is set for the session and Jetty does not automatically dispose of the session. Over multiple git actions, this can lead to a heap memory exhaustion for Gerrit servers. We recommend upgrading Gerrit to any of the versions listed above.
Affected products
- Gerrit: before 2.15.22; from 2.16.0 before 2.16.26; from 3.0.0 before 3.0.16; from 3.1.0 before 3.1.12; from 3.2.0 before 3.2.7; from 3.3.0 before 3.3.2 — fixed in 2.15.22, 2.16.26, 3.0.16, 3.1.12, 3.2.7, 3.3.2
How to fix
Upgrade to a fixed version: Gerrit 2.15.22, 2.16.26, 3.0.16, 3.1.12. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/gerrit/issues/detail?id=13858
- https://bugs.chromium.org/p/gerrit/issues/detail?id=13858
Get alerted when CVE-2021-22553 or the next vulnerability affects your stack