What’s Vulnerable › Vulnerabilities
CVE-2021-22556: Integer Overflow in Fuchsia Kernel
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-03 · updated 2026-06-17
- Weakness: CWE-190
Description
The Security Team discovered an integer overflow bug that allows an attacker with code execution to issue memory cache invalidation operations on pages that they don’t own, allowing them to control kernel memory from userspace. We recommend upgrading to kernel version 4.1 or beyond.
Affected products
- Google LLC Fuchsia Kernel: before 4.1 — fixed in 4.1
How to fix
Upgrade to a fixed version: Google LLC Fuchsia Kernel 4.1. Check the vendor advisory for mitigations.
References
- https://fuchsia-review.googlesource.com/c/fuchsia/+/570881
- https://fuchsia.dev/whats-new/release-notes/f4-1
- https://fuchsia-review.googlesource.com/c/fuchsia/+/570881
- https://fuchsia.dev/whats-new/release-notes/f4-1
Get alerted when CVE-2021-22556 or the next vulnerability affects your stack