What’s Vulnerable › Vulnerabilities
CVE-2021-22567: Bidirectional Override in Dart SDK
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-05 · updated 2026-06-17
- Weakness: CWE-284
Description
Bidirectional Unicode text can be interpreted and compiled differently than how it appears in editors which can be exploited to get nefarious code passed a code review by appearing benign. An attacker could embed a source that is invisible to a code reviewer that modifies the behavior of a program in unexpected ways.
Affected products
- Google LLC Dart SDK: before 2.15.0 — fixed in 2.15.0
How to fix
Upgrade to a fixed version: Google LLC Dart SDK 2.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/dart-lang/sdk/blob/main/CHANGELOG.md
- https://github.com/dart-lang/sdk/commit/52519ea8eb4780c468c4c2ed00e7c8046ccfed41
- https://github.com/dart-lang/sdk/blob/main/CHANGELOG.md
- https://github.com/dart-lang/sdk/commit/52519ea8eb4780c468c4c2ed00e7c8046ccfed41
Get alerted when CVE-2021-22567 or the next vulnerability affects your stack