What’s Vulnerable › Vulnerabilities
CVE-2021-22600: Linux Kernel Privilege Escalation Vulnerability
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2022-04-11
- EPSS: 6.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-26 · updated 2026-06-17
- Weakness: CWE-415
Description
A double free bug in packet_set_ring() in net/packet/af_packet.c can be exploited by a local user through crafted syscalls to escalate privileges or deny service. We recommend upgrading kernel past the effected versions or rebuilding past ec6af094ea28f0f2dda1a6a33b14cd57e36a9755
Affected products
- Debian Linux: 9.0, 10.0
- Linux kernel: from 4.14.175 before 4.14.259; from 4.19.114 before 4.19.222; from 5.4.29 before 5.4.168; from 5.5.14 before 5.10.88; from 5.11 before 5.15.11 — fixed in 4.14.259, 4.19.222, 5.10.88, 5.15.11, 5.4.168
- NetApp 8300 Firmware: all versions
- NetApp 8700 Firmware: all versions
- NetApp A400 Firmware: all versions
- NetApp C400 Firmware: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
How to fix
Upgrade to a fixed version: Linux kernel 4.14.259, 4.19.222, 5.10.88, 5.15.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit?id=ec6af094ea28f0f2dda1a6a33b14cd57e36a9755
- https://lists.debian.org/debian-lts-announce/2022/03/msg00012.html
- https://security.netapp.com/advisory/ntap-20230110-0002/
- https://www.debian.org/security/2022/dsa-5096
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit?id=ec6af094ea28f0f2dda1a6a33b14cd57e36a9755
- https://lists.debian.org/debian-lts-announce/2022/03/msg00012.html
- https://security.netapp.com/advisory/ntap-20230110-0002/
- https://www.debian.org/security/2022/dsa-5096
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-22600
Get alerted when CVE-2021-22600 or the next vulnerability affects your stack