What’s Vulnerable › Vulnerabilities
CVE-2021-22641
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-27 · updated 2026-06-17
- Weakness: CWE-122
Description
A heap-based buffer overflow issue has been identified in the way the application processes project files, allowing an attacker to craft a special project file that may allow arbitrary code execution on the Tellus Lite V-Simulator and V-Server Lite (versions prior to 4.0.10.0).
Affected products
- Fuji Electric V-Server Lite: before 4.0.10.0 — fixed in 4.0.10.0
- Fujielectric V-Simulator: before 4.0.10.0 — fixed in 4.0.10.0
How to fix
Upgrade to a fixed version: Fuji Electric V-Server Lite 4.0.10.0; Fujielectric V-Simulator 4.0.10.0. Check the vendor advisory for mitigations.
References
- https://us-cert.cisa.gov/ics/advisories/icsa-21-026-01
- https://www.zerodayinitiative.com/advisories/ZDI-21-099/
- https://us-cert.cisa.gov/ics/advisories/icsa-21-026-01
- https://www.zerodayinitiative.com/advisories/ZDI-21-099/
Get alerted when CVE-2021-22641 or the next vulnerability affects your stack