What’s Vulnerable › Vulnerabilities
CVE-2021-22663
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-02-09 · updated 2026-06-17
- Weakness: CWE-125
Description
Cscape (All versions prior to 9.90 SP3.5) lacks proper validation of user-supplied data when parsing project files. This could lead to an out-of-bounds read. An attacker could leverage this vulnerability to execute code in the context of the current process.
Affected products
- Horner Automation Cscape: before 9.90 — fixed in 9.90
- Siemens Cscape: 9.90, 9.90-sp1, 9.90-sp3
How to fix
Upgrade to a fixed version: Horner Automation Cscape 9.90. Check the vendor advisory for mitigations.
References
- https://us-cert.cisa.gov/ics/advisories/icsa-21-035-02
- https://us-cert.cisa.gov/ics/advisories/icsa-21-035-02
Get alerted when CVE-2021-22663 or the next vulnerability affects your stack