What’s Vulnerable › Vulnerabilities
CVE-2021-22682
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-04-23 · updated 2026-06-17
- Weakness: CWE-284
Description
Cscape (All versions prior to 9.90 SP4) is configured by default to be installed for all users, which allows full permissions, including read/write access. This may allow unprivileged users to modify the binaries and configuration files and lead to local privilege escalation.
Affected products
- Horner Automation Cscape: before 9.90; 9.90, 9.90-sp1, 9.90-sp2, 9.90-sp3 — fixed in 9.90
How to fix
Upgrade to a fixed version: Horner Automation Cscape 9.90. Check the vendor advisory for mitigations.
References
- https://us-cert.cisa.gov/ics/advisories/icsa-21-112-01
- https://us-cert.cisa.gov/ics/advisories/icsa-21-112-01
Get alerted when CVE-2021-22682 or the next vulnerability affects your stack