What’s Vulnerable › Vulnerabilities
CVE-2021-22864: Unsafe configuration options in GitHub Pages leading to remote code execution on GitHub Enterprise Server
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-23 · updated 2026-06-17
- Weakness: CWE-77
Description
A remote code execution vulnerability was identified in GitHub Enterprise Server that could be exploited when building a GitHub Pages site. User-controlled configuration options used by GitHub Pages were not sufficiently restricted and made it possible to override environment variables leading to code execution on the GitHub Enterprise Server instance. To exploit this vulnerability, an attacker would need permission to create and build a GitHub Pages site on the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.0.3 and was fixed in 3.0.3, 2.22.9, and 2.21.17. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: from 2.21.0 before 2.21.17; from 2.22.0 before 2.22.9; from 3.0.0 before 3.0.3 — fixed in 2.21.17, 2.22.9, 3.0.3
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 2.21.17, 2.22.9, 3.0.3. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server%402.21/admin/release-notes#2.21.17
- https://docs.github.com/en/enterprise-server%402.22/admin/release-notes#2.22.9
- https://docs.github.com/en/enterprise-server%403.0/admin/release-notes#3.0.3
- https://docs.github.com/en/enterprise-server%402.21/admin/release-notes#2.21.17
- https://docs.github.com/en/enterprise-server%402.22/admin/release-notes#2.22.9
- https://docs.github.com/en/enterprise-server%403.0/admin/release-notes#3.0.3
Get alerted when CVE-2021-22864 or the next vulnerability affects your stack