What’s Vulnerable › Vulnerabilities
CVE-2021-22872
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Revive Adserver before 5.1.0 is vulnerable to a reflected cross-site scripting (XSS) vulnerability via the publicly accessible afr.php delivery script. While this issue was previously addressed in modern browsers as CVE-2020-8115, some older browsers (e.g., IE10) that do not automatically URL encode parameters were still vulnerable.
Affected products
- Revive Adserver: before 5.1.0 — fixed in 5.1.0
How to fix
Upgrade to a fixed version: Revive Adserver 5.1.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/161070/Revive-Adserver-5.0.5-Cross-Site-Scripting-Open-Redirect.html
- http://seclists.org/fulldisclosure/2021/Jan/60
- https://github.com/revive-adserver/revive-adserver/commit/00fdb8d0e
- https://github.com/revive-adserver/revive-adserver/commit/1dbcf7d50
- https://hackerone.com/reports/986365
- https://www.revive-adserver.com/security/revive-sa-2021-001/
- http://packetstormsecurity.com/files/161070/Revive-Adserver-5.0.5-Cross-Site-Scripting-Open-Redirect.html
- http://seclists.org/fulldisclosure/2021/Jan/60
- https://github.com/revive-adserver/revive-adserver/commit/00fdb8d0e
- https://github.com/revive-adserver/revive-adserver/commit/1dbcf7d50
- https://hackerone.com/reports/986365
- https://www.revive-adserver.com/security/revive-sa-2021-001/
Get alerted when CVE-2021-22872 or the next vulnerability affects your stack