What’s Vulnerable › Vulnerabilities
CVE-2021-22873
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 69.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-26 · updated 2026-06-17
- Weakness: CWE-601
Description
Revive Adserver before 5.1.0 is vulnerable to open redirects via the `dest`, `oadest`, and/or `ct0` parameters of the lg.php and ck.php delivery scripts. Such open redirects had previously been available by design to allow third party ad servers to track such metrics when delivering ads. However, third party click tracking via redirects is not a viable option anymore, leading to such open redirect functionality being removed and reclassified as a vulnerability.
Affected products
- Revive Adserver: before 5.1.0 — fixed in 5.1.0
How to fix
Upgrade to a fixed version: Revive Adserver 5.1.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/161070/Revive-Adserver-5.0.5-Cross-Site-Scripting-Open-Redirect.html
- http://seclists.org/fulldisclosure/2021/Jan/60
- https://github.com/revive-adserver/revive-adserver/issues/1068
- https://hackerone.com/reports/1081406
- https://www.revive-adserver.com/security/revive-sa-2021-001/
- http://packetstormsecurity.com/files/161070/Revive-Adserver-5.0.5-Cross-Site-Scripting-Open-Redirect.html
- http://seclists.org/fulldisclosure/2021/Jan/60
- https://github.com/revive-adserver/revive-adserver/issues/1068
- https://hackerone.com/reports/1081406
- https://www.revive-adserver.com/security/revive-sa-2021-001/
Get alerted when CVE-2021-22873 or the next vulnerability affects your stack