What’s Vulnerable › Vulnerabilities
CVE-2021-22874
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-01-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Revive Adserver before 5.1.1 is vulnerable to a reflected XSS vulnerability in userlog-index.php via the `period_preset` parameter.
Affected products
- Revive Adserver: before 5.1.1 — fixed in 5.1.1
How to fix
Upgrade to a fixed version: Revive Adserver 5.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/revive-adserver/revive-adserver/commit/e2a67ce8
- https://hackerone.com/reports/1083231
- https://www.revive-adserver.com/security/revive-sa-2021-002/
- https://github.com/revive-adserver/revive-adserver/commit/e2a67ce8
- https://hackerone.com/reports/1083231
- https://www.revive-adserver.com/security/revive-sa-2021-002/
Get alerted when CVE-2021-22874 or the next vulnerability affects your stack