What’s Vulnerable › Vulnerabilities
CVE-2021-22878
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Nextcloud Server prior to 20.0.6 is vulnerable to reflected cross-site scripting (XSS) due to lack of sanitization in `OC.Notification.show`.
Affected products
- Fedoraproject Fedora: 34
- Nextcloud Server: before 20.0.6 — fixed in 20.0.6
How to fix
Upgrade to a fixed version: Nextcloud Server 20.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/server/pull/25234
- https://hackerone.com/reports/896522
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L6BO6P6MP2MOWA6PZRXX32PLWPXN5O4S/
- https://nextcloud.com/security/advisory/?id=NC-SA-2021-005
- https://github.com/nextcloud/server/pull/25234
- https://hackerone.com/reports/896522
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L6BO6P6MP2MOWA6PZRXX32PLWPXN5O4S/
- https://nextcloud.com/security/advisory/?id=NC-SA-2021-005
Get alerted when CVE-2021-22878 or the next vulnerability affects your stack