What’s Vulnerable › Vulnerabilities

CVE-2021-22883

Description

Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established. This leads to a leak of file descriptors. If a file descriptor limit is configured on the system, then the server is unable to accept new connections and prevent the process also from opening, e.g. a file. If no file descriptor limit is configured, then this lead to an excessive memory usage and cause the system to run out of memory.

Affected products

How to fix

Upgrade to a fixed version: Node.js 10.24.0, 12.21.0, 14.16.0, 15.10.0; Oracle Corporation JD Edwards EnterpriseOne Tools 9.2.6.0; Oracle Nosql Database 20.3; Siemens Sinec Infrastructure Network Services 1.0.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-22883 or the next vulnerability affects your stack