What’s Vulnerable › Vulnerabilities

CVE-2021-22886

Description

Rocket.Chat before 3.11, 3.10.5, 3.9.7, 3.8.8 is vulnerable to persistent cross-site scripting (XSS) using nested markdown tags allowing a remote attacker to inject arbitrary JavaScript in a message. This flaw leads to arbitrary file read and RCE on Rocket.Chat desktop app.

Affected products

How to fix

Upgrade to a fixed version: Rocket.Chat 3.10.5, 3.8.8, 3.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-22886 or the next vulnerability affects your stack