What’s Vulnerable › Vulnerabilities
CVE-2021-22889
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Revive Adserver before v5.2.0 is vulnerable to a reflected XSS vulnerability in the `statsBreakdown` parameter of stats.php (and possibly other scripts) due to single quotes not being escaped. An attacker could trick a user with access to the user interface of a Revive Adserver instance into clicking on a specifically crafted URL and pressing a certain key combination to execute injected JavaScript code.
Affected products
- Revive Adserver: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: Revive Adserver 5.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/revive-adserver/revive-adserver/commit/2f868414
- https://hackerone.com/reports/1097217
- https://www.revive-adserver.com/security/revive-sa-2021-003/
- https://github.com/revive-adserver/revive-adserver/commit/2f868414
- https://hackerone.com/reports/1097217
- https://www.revive-adserver.com/security/revive-sa-2021-003/
Get alerted when CVE-2021-22889 or the next vulnerability affects your stack