What’s Vulnerable › Vulnerabilities
CVE-2021-22895
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-11 · updated 2026-06-17
- Weakness: CWE-295
Description
Nextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the "Register with a Provider" flow.
Affected products
- Debian Linux: 10.0, 11.0
- Desktop Client: before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: Desktop Client 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/desktop/pull/2926
- https://github.com/nextcloud/desktop/releases/tag/v3.1.3
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-qpgp-vf4p-wcw5
- https://hackerone.com/reports/903424
- https://www.debian.org/security/2021/dsa-4974
- https://github.com/nextcloud/desktop/pull/2926
- https://github.com/nextcloud/desktop/releases/tag/v3.1.3
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-qpgp-vf4p-wcw5
- https://hackerone.com/reports/903424
- https://www.debian.org/security/2021/dsa-4974
Get alerted when CVE-2021-22895 or the next vulnerability affects your stack