What’s Vulnerable › Vulnerabilities
CVE-2021-22907
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-27 · updated 2026-06-17
- Weakness: CWE-284
Description
An improper access control vulnerability exists in Citrix Workspace App for Windows potentially allows privilege escalation in CR versions prior to 2105 and 1912 LTSR prior to CU4.
Affected products
- Citrix Workspace app for Windows: before 19.12.4000; before 2105 — fixed in 19.12.4000, 2105
- Citrix Workspace App for Windows: Citrix Workspace App for Windows 2105 and 1912 LTSR CU4
How to fix
Upgrade to a fixed version: Citrix Workspace app for Windows 19.12.4000, 2105. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-22907 or the next vulnerability affects your stack