What’s Vulnerable › Vulnerabilities

CVE-2021-22915

Description

Nextcloud server before 19.0.11, 20.0.10, 21.0.2 is vulnerable to brute force attacks due to lack of inclusion of IPv6 subnets in rate-limiting considerations. This could potentially result in an attacker bypassing rate-limit controls such as the Nextcloud brute-force protection.

Affected products

How to fix

Upgrade to a fixed version: Nextcloud Server 19.0.11, 20.0.10, 21.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-22915 or the next vulnerability affects your stack