What’s Vulnerable › Vulnerabilities

CVE-2021-22921

Description

Node.js before 16.4.1, 14.17.2, and 12.22.2 is vulnerable to local privilege escalation attacks under certain conditions on Windows platforms. More specifically, improper configuration of permissions in the installation directory allows an attacker to perform two different escalation attacks: PATH and DLL hijacking.

Affected products

How to fix

Upgrade to a fixed version: Node.js 12.22.2, 14.17.2, 16.4.1; Siemens Sinec Infrastructure Network Services 1.0.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-22921 or the next vulnerability affects your stack