What’s Vulnerable › Vulnerabilities

CVE-2021-22931

Description

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can lead to output of wrong hostnames (leading to Domain Hijacking) and injection vulnerabilities in applications using the library.

Affected products

How to fix

Upgrade to a fixed version: Node.js 12.22.5, 14.17.5, 16.6.2; Siemens Sinec Infrastructure Network Services 1.0.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-22931 or the next vulnerability affects your stack