What’s Vulnerable › Vulnerabilities
CVE-2021-22948
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-09-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Vulnerability in the generation of session IDs in revive-adserver < 5.3.0, based on the cryptographically insecure uniqid() PHP function. Under some circumstances, an attacker could theoretically be able to brute force session IDs in order to take over a specific account.
Affected products
- Revive Adserver: before 5.3.0; 5.3.0-rc1 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: Revive Adserver 5.3.0. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/1187820
- https://www.revive-adserver.com/security/revive-sa-2021-005/
- https://hackerone.com/reports/1187820
- https://www.revive-adserver.com/security/revive-sa-2021-005/
Get alerted when CVE-2021-22948 or the next vulnerability affects your stack