What’s Vulnerable › Vulnerabilities
CVE-2021-22956
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-07 · updated 2026-06-17
- Weakness: CWE-400
Description
An uncontrolled resource consumption vulnerability exists in Citrix ADC <13.0-83.27, <12.1-63.22 and 11.1-65.23 that could allow an attacker with access to NSIP or SNIP with management interface access to cause a temporary disruption of the Management GUI, Nitro API, and RPC communication.
Affected products
- Citrix Application Delivery Controller Firmware: before 11.1-65.23; from 12.1 before 12.1-63.22; from 13.0 before 13.0-83.27 — fixed in 11.1-65.23, 12.1-63.22, 13.0-83.27
- NetScaler Gateway: before 11.1-65.23; from 12.1 before 12.1-63.22; from 13.0 before 13.0-65.23 — fixed in 11.1-65.23, 12.1-63.22, 13.0-65.23
- Citrix SD-WAN Center: before 10.2.9c; from 11.4.0 before 11.4.2 — fixed in 10.2.9c, 11.4.2
- Citrix ADC, Citrix Gateway, Citrix SDWAN: Citrix ADC 11.1,12.1,13.0,13.1
How to fix
Upgrade to a fixed version: Citrix Application Delivery Controller Firmware 11.1-65.23, 12.1-63.22, 13.0-83.27; NetScaler Gateway 11.1-65.23, 12.1-63.22, 13.0-65.23; Citrix SD-WAN Center 10.2.9c, 11.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-22956 or the next vulnerability affects your stack