What’s Vulnerable › Vulnerabilities
CVE-2021-22959
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-15 · updated 2026-06-17
- Weakness: CWE-444
Description
The parser in accepts requests with a space (SP) right after the header name before the colon. This can lead to HTTP Request Smuggling (HRS) in llhttp < v2.1.4 and < v6.0.6.
Affected products
- Debian Linux: 11.0
- Llhttp: before 2.1.4; from 3.0.0 before 6.0.6 — fixed in 2.1.4, 6.0.6
- Oracle Corporation GraalVM Enterprise Edition: 20.3.4, 21.3.0
How to fix
Upgrade to a fixed version: Llhttp 2.1.4, 6.0.6. Check the vendor advisory for mitigations.
References
- https://hackerone.com/reports/1238709
- https://www.debian.org/security/2022/dsa-5170
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://hackerone.com/reports/1238709
- https://www.debian.org/security/2022/dsa-5170
- https://www.oracle.com/security-alerts/cpujan2022.html
Get alerted when CVE-2021-22959 or the next vulnerability affects your stack