What’s Vulnerable › Vulnerabilities

CVE-2021-22978

Description

On BIG-IP version 16.0.x before 16.0.1, 15.1.x before 15.1.1, 14.1.x before 14.1.3.1, 13.1.x before 13.1.3.5, and all 12.1.x and 11.6.x versions, undisclosed endpoints in iControl REST allow for a reflected XSS attack, which could lead to a complete compromise of BIG-IP if the victim user is granted the admin role. Note: Software versions which have reached End of Software Development (EoSD) are not evaluated.

Affected products

How to fix

Upgrade to a fixed version: F5 BIG-IP APM 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; BIG-IP 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; F5 Big-Ip Advanced Web Application Firewall 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; F5 Big-Ip Analytics 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; F5 Networks, Inc. BIG-IP (AAM) 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; BIG-IP ASM 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; F5 Big-Ip Ddos Hybrid Defender 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; F5 BIG-IP DNS 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; F5 Big-Ip Fraud Protection Service 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; F5 Big-Ip Global Traffic Manager 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; F5 Big-Ip Link Controller 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1; F5 BIG-IP (LTM) 13.1.3.5, 14.1.3.1, 15.1.1, 16.0.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-22978 or the next vulnerability affects your stack