What’s Vulnerable › Vulnerabilities

CVE-2021-23012

Description

On BIG-IP versions 16.0.x before 16.0.1.1, 15.1.x before 15.1.3, 14.1.x before 14.1.4, and 13.1.x before 13.1.4, lack of input validation for items used in the system support functionality may allow users granted either "Resource Administrator" or "Administrator" roles to execute arbitrary bash commands on BIG-IP. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Affected products

How to fix

Upgrade to a fixed version: F5 BIG-IP APM 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; BIG-IP 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; F5 Big-Ip Advanced Web Application Firewall 13.1.4, 15.1.3, 16.0.1.1; F5 Big-Ip Analytics 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; F5 Networks, Inc. BIG-IP (AAM) 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; BIG-IP ASM 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; F5 Big-Ip Ddos Hybrid Defender 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; F5 BIG-IP DNS 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; F5 Big-Ip Fraud Protection Service 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; F5 Big-Ip Global Traffic Manager 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; F5 Big-Ip Link Controller 13.1.4, 14.1.4, 15.1.3, 16.0.1.1; F5 BIG-IP (LTM) 13.1.4, 14.1.4, 15.1.3, 16.0.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-23012 or the next vulnerability affects your stack