What’s Vulnerable › Vulnerabilities
CVE-2021-23017
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 53.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-193
Description
A security issue in nginx resolver was identified, which might allow an attacker who is able to forge UDP packets from the DNS server to cause 1-byte memory overwrite, resulting in worker process crash or potential other impact.
Affected products
- nginx: from 0.6.18 before 1.20.1 — fixed in 1.20.1
- Fedoraproject Fedora: 33, 34
- NetApp ONTAP Select Deploy administration utility: all versions
- openresty: before 1.19.3.2 — fixed in 1.19.3.2
- Oracle Blockchain Platform: before 21.1.2 — fixed in 21.1.2
- Oracle Communications Control Plane Monitor: 3.4, 4.2, 4.3, 4.4
- Oracle Communications Fraud Monitor: from 3.4 through 4.4
- Oracle Corporation Communications Operations Monitor: 3.4, 4.2, 4.3, 4.4
- Oracle Corporation Communications Session Border Controller: 8.4, 9.0
- Oracle Corporation Enterprise Communications Broker: 3.3.0
- Oracle Corporation Enterprise Session Border Controller: 8.4, 9.0
- Oracle Enterprise Telephony Fraud Monitor: 3.4, 4.2, 4.3, 4.4
- Oracle Corporation Oracle GoldenGate: before 21.4.0.0.0 — fixed in 21.4.0.0.0
How to fix
Upgrade to a fixed version: nginx 1.20.1; openresty 1.19.3.2; Oracle Blockchain Platform 21.1.2; Oracle Corporation Oracle GoldenGate 21.4.0.0.0. Check the vendor advisory for mitigations.
References
- http://mailman.nginx.org/pipermail/nginx-announce/2021/000300.html
- http://packetstormsecurity.com/files/167720/Nginx-1.20.0-Denial-Of-Service.html
- https://lists.apache.org/thread.html/r37e6b2165f7c910d8e15fd54f4697857619ad2625f56583802004009%40%3Cnotifications.apisix.apache.org%3E
- https://lists.apache.org/thread.html/r4d4966221ca399ce948ef34884652265729d7d9ef8179c78d7f17e7f%40%3Cnotifications.apisix.apache.org%3E
- https://lists.apache.org/thread.html/r6fc5c57b38e93e36213e9a18c8a4e5dbd5ced1c7e57f08a1735975ba%40%3Cnotifications.apisix.apache.org%3E
- https://lists.apache.org/thread.html/rf232eecd47fdc44520192810560303073cefd684b321f85e311bad31%40%3Cnotifications.apisix.apache.org%3E
- https://lists.apache.org/thread.html/rf318aeeb4d7a3a312734780b47de83cefb7e6995da0b2cae5c28675c%40%3Cnotifications.apisix.apache.org%3E
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7SFVYHC7OXTEO4SMBWXDVK6E5IMEYMEE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GNKOP2JR5L7KCIZTJRZDCUPJTUONMC5I/
- https://security.netapp.com/advisory/ntap-20210708-0006/
- https://support.f5.com/csp/article/K12331123%2C
- https://www.oracle.com/security-alerts/cpuapr2022.html
Get alerted when CVE-2021-23017 or the next vulnerability affects your stack