What’s Vulnerable › Vulnerabilities
CVE-2021-23019
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-201
Description
The NGINX Controller 2.0.0 thru 2.9.0 and 3.x before 3.15.0 Administrator password may be exposed in the systemd.txt file that is included in the NGINX support package.
Affected products
- NGINX Controller: from 2.0.0 through 2.9.0; from 3.0.0 before 3.15.0 — fixed in 3.15.0
How to fix
Upgrade to a fixed version: NGINX Controller 3.15.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-23019 or the next vulnerability affects your stack