What’s Vulnerable › Vulnerabilities
CVE-2021-23020
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-330
Description
The NAAS 3.x before 3.10.0 API keys were generated using an insecure pseudo-random string and hashing algorithm which could lead to predictable keys.
Affected products
- NGINX Controller: from 3.0.0 before 3.10.0 — fixed in 3.10.0
How to fix
Upgrade to a fixed version: NGINX Controller 3.10.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-23020 or the next vulnerability affects your stack