What’s Vulnerable › Vulnerabilities
CVE-2021-23021
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-01 · updated 2026-06-17
- Weakness: CWE-732
Description
The Nginx Controller 3.x before 3.7.0 agent configuration file /etc/controller-agent/agent.conf is world readable with current permission bits set to 644.
Affected products
- NGINX Controller: from 3.0.0 before 3.7.0 — fixed in 3.7.0
How to fix
Upgrade to a fixed version: NGINX Controller 3.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-23021 or the next vulnerability affects your stack