What’s Vulnerable › Vulnerabilities
CVE-2021-23029
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-14 · updated 2026-06-17
- Weakness: CWE-918
Description
On version 16.0.x before 16.0.1.2, insufficient permission checks may allow authenticated users with guest privileges to perform Server-Side Request Forgery (SSRF) attacks through F5 Advanced Web Application Firewall (WAF) and the BIG-IP ASM Configuration utility. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 Big-Ip Advanced Web Application Firewall: from 16.0.0 before 16.0.1.2 — fixed in 16.0.1.2
- BIG-IP ASM: from 16.0.0 before 16.0.1.2 — fixed in 16.0.1.2
How to fix
Upgrade to a fixed version: F5 Big-Ip Advanced Web Application Firewall 16.0.1.2; BIG-IP ASM 16.0.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-23029 or the next vulnerability affects your stack