What’s Vulnerable › Vulnerabilities

CVE-2021-23041

Description

On BIG-IP version 16.0.x before 16.0.1.2, 15.1.x before 15.1.3, 14.1.x before 14.1.4.2, 13.1.x before 13.1.4.1, and all versions of 12.1.x, a DOM based cross-site scripting (XSS) vulnerability exists in an undisclosed page of the BIG-IP Configuration utility that allows an attacker to execute JavaScript in the context of the current logged-in user. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Affected products

How to fix

Upgrade to a fixed version: F5 BIG-IP APM 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; BIG-IP 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; F5 Big-Ip Advanced Web Application Firewall 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; F5 Big-Ip Analytics 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; F5 Networks, Inc. BIG-IP (AAM) 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; BIG-IP ASM 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; F5 BIG-IP DNS 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; F5 Big-Ip Fraud Protection Service 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; F5 Big-Ip Global Traffic Manager 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; F5 Big-Ip Link Controller 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2; F5 BIG-IP (LTM) 13.1.4.1, 14.1.4.2, 15.1.3, 16.0.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-23041 or the next vulnerability affects your stack