What’s Vulnerable › Vulnerabilities
CVE-2021-23047
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-14 · updated 2026-06-17
- Weakness: CWE-400
Description
On version 16.x before 16.1.0, 15.1.x before 15.1.3.1, 14.1.x before 14.1.4.3, and all versions of 13.1.x, 12.1.x and 11.6.x, when BIG-IP APM performs Online Certificate Status Protocol (OCSP) verification of a certificate that contains Authority Information Access (AIA), undisclosed requests may cause an increase in memory use. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 BIG-IP APM: from 11.6.1 through 11.6.5; from 12.1.0 through 12.1.6; from 13.1.0 before 13.1.4; from 14.1.0 before 14.1.4.3; from 15.1.0 before 15.1.3.1; from 16.0.0 through 16.0.1 — fixed in 13.1.4, 14.1.4.3, 15.1.3.1
How to fix
Upgrade to a fixed version: F5 BIG-IP APM 13.1.4, 14.1.4.3, 15.1.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-23047 or the next vulnerability affects your stack