What’s Vulnerable › Vulnerabilities
CVE-2021-23055
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-21 · updated 2026-06-17
- Weakness: CWE-732
Description
On version 2.x before 2.0.3 and 1.x before 1.12.3, the command line restriction that controls snippet use with NGINX Ingress Controller does not apply to Ingress objects. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Ingress Controller: from 1.0.0 before 1.12.3; from 2.0.0 before 2.0.3 — fixed in 1.12.3, 2.0.3
How to fix
Upgrade to a fixed version: F5 NGINX Ingress Controller 1.12.3, 2.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-23055 or the next vulnerability affects your stack