What’s Vulnerable › Vulnerabilities
CVE-2021-23140
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-06-11 · updated 2026-06-17
- Weakness: CWE-285
Description
Improper Authorization vulnerability in Gallagher Command Centre Server allows command line macros to be modified by an unauthorised Command Centre Operator. This issue affects: Gallagher Command Centre 8.40 versions prior to 8.40.1888 (MR3); 8.30 versions prior to 8.30.1359 (MR3); 8.20 versions prior to 8.20.1259 (MR5); version 8.10 and prior versions.
Affected products
- Gallagher Command Centre: through 8.10; from 8.20 before 8.20.1259; from 8.30 before 8.30.1359; from 8.40 before 8.40.1888 — fixed in 8.20.1259, 8.30.1359, 8.40.1888
How to fix
Upgrade to a fixed version: Gallagher Command Centre 8.20.1259, 8.30.1359, 8.40.1888. Check the vendor advisory for mitigations.
References
- https://security.gallagher.com/Security-Advisories/CVE-2021-23140
- https://security.gallagher.com/Security-Advisories/CVE-2021-23140
Get alerted when CVE-2021-23140 or the next vulnerability affects your stack