What’s Vulnerable › Vulnerabilities
CVE-2021-23165
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-03-16 · updated 2026-06-17
- Weakness: CWE-122
Description
A flaw was found in htmldoc before v1.9.12. Heap buffer overflow in pspdf_prepare_outpages(), in ps-pdf.cxx may lead to execute arbitrary code and denial of service.
Affected products
- htmldoc: before 1.9.12 — fixed in 1.9.12
How to fix
Upgrade to a fixed version: htmldoc 1.9.12. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1967014
- https://github.com/michaelrsweet/htmldoc/commit/6e8a95561988500b5b5ae4861b3b0cbf4fba517f
- https://github.com/michaelrsweet/htmldoc/commit/6e8a95561988500b5b5ae4861b3b0cbf4fba517f.patch
- https://github.com/michaelrsweet/htmldoc/issues/413
- https://bugzilla.redhat.com/show_bug.cgi?id=1967014
- https://github.com/michaelrsweet/htmldoc/commit/6e8a95561988500b5b5ae4861b3b0cbf4fba517f
- https://github.com/michaelrsweet/htmldoc/commit/6e8a95561988500b5b5ae4861b3b0cbf4fba517f.patch
- https://github.com/michaelrsweet/htmldoc/issues/413
Get alerted when CVE-2021-23165 or the next vulnerability affects your stack