What’s Vulnerable › Vulnerabilities
CVE-2021-23174: WordPress Download Monitor plugin <= 4.4.6 - Auth. Stored Cross-Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 83.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-01-28 · updated 2026-06-17
- Weakness: CWE-79
Description
Authenticated (admin+) Persistent Cross-Site Scripting (XSS) vulnerability discovered in Download Monitor WordPress plugin (versions <= 4.4.6) Vulnerable parameters: &post_title, &downloadable_file_version[0].
Affected products
- wpchill Download Monitor: before 4.4.7 — fixed in 4.4.7
How to fix
Upgrade to a fixed version: wpchill Download Monitor 4.4.7. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/download-monitor/wordpress-download-monitor-plugin-4-4-6-authenticated-persistent-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/download-monitor/wordpress-download-monitor-plugin-4-4-6-authenticated-persistent-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2021-23174 or the next vulnerability affects your stack