What’s Vulnerable › Vulnerabilities
CVE-2021-23192
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-02 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in the way samba implemented DCE/RPC. If a client to a Samba server sent a very large DCE/RPC request, and chose to fragment it, an attacker could replace later fragments with their own data, bypassing the signature requirements.
Affected products
- Samba: from 4.10.0 before 4.13.14; from 4.14.0 before 4.14.10; from 4.15.0 before 4.15.2 — fixed in 4.13.14, 4.14.10, 4.15.2
How to fix
Upgrade to a fixed version: Samba 4.13.14, 4.14.10, 4.15.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2019666
- https://security.gentoo.org/glsa/202309-06
- https://ubuntu.com/security/CVE-2021-23192
- https://www.samba.org/samba/security/CVE-2021-23192.html
- https://bugzilla.redhat.com/show_bug.cgi?id=2019666
- https://security.gentoo.org/glsa/202309-06
- https://ubuntu.com/security/CVE-2021-23192
- https://www.samba.org/samba/security/CVE-2021-23192.html
Get alerted when CVE-2021-23192 or the next vulnerability affects your stack