What’s Vulnerable › Vulnerabilities
CVE-2021-23222
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-02 · updated 2026-06-17
- Weakness: CWE-522
Description
A man-in-the-middle attacker can inject false responses to the client's first few queries, despite the use of SSL certificate verification and encryption.
Affected products
- PostgreSQL: from 9.6 before 9.6.24; from 10.0 before 10.19; from 11.0 before 11.14; from 12.0 before 12.9; from 13.0 before 13.5; 14.0 — fixed in 10.19, 11.14, 12.9, 13.5, 9.6.24
How to fix
Upgrade to a fixed version: PostgreSQL 10.19, 11.14, 12.9, 13.5. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2022675
- https://git.postgresql.org/gitweb/?p=postgresql.git%3Ba=commitdiff%3Bh=d83cdfdca9d918bbbd6bb209139b94c954da7228
- https://github.com/postgres/postgres/commit/160c0258802d10b0600d7671b1bbea55d8e17d45
- https://security.gentoo.org/glsa/202211-04
- https://www.postgresql.org/support/security/CVE-2021-23222/
- https://bugzilla.redhat.com/show_bug.cgi?id=2022675
- https://git.postgresql.org/gitweb/?p=postgresql.git%3Ba=commitdiff%3Bh=d83cdfdca9d918bbbd6bb209139b94c954da7228
- https://github.com/postgres/postgres/commit/160c0258802d10b0600d7671b1bbea55d8e17d45
- https://security.gentoo.org/glsa/202211-04
- https://www.postgresql.org/support/security/CVE-2021-23222/
Get alerted when CVE-2021-23222 or the next vulnerability affects your stack