What’s Vulnerable › Vulnerabilities
CVE-2021-23258: Spring SPEL Expression Language Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-02 · updated 2026-06-17
- Weakness: CWE-913
Description
Authenticated users with Administrator or Developer roles may execute OS commands by SPEL Expression in Spring beans. SPEL Expression does not have security restrictions, which will cause attackers to execute arbitrary commands remotely (RCE).
Affected products
- Crafter Software Crafter CMS: from 3.1.0 before 3.1.12 — fixed in 3.1.12
How to fix
Upgrade to a fixed version: Crafter Software Crafter CMS 3.1.12. Check the vendor advisory for mitigations.
References
- https://docs.craftercms.org/en/3.1/security/advisory.html#cv-2021120101
- https://docs.craftercms.org/en/3.1/security/advisory.html#cv-2021120101
Get alerted when CVE-2021-23258 or the next vulnerability affects your stack