What’s Vulnerable › Vulnerabilities
CVE-2021-23283: Security issues in Eaton Intelligent Power Protector (IPP)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Eaton Intelligent Power Protector (IPP) prior to version 1.69 is vulnerable to stored Cross Site Scripting. The vulnerability exists due to insufficient validation of user input and improper encoding of the output for certain resources within the IPP software.
Affected products
- Eaton Intelligent Power Protector: before 1.69 — fixed in 1.69
How to fix
Upgrade to a fixed version: Eaton Intelligent Power Protector 1.69. Check the vendor advisory for mitigations.
References
- https://www.eaton.com/content/dam/eaton/company/news-insights/cybersecurity/security-bulletins/Eaton-Intelligent-Power-Protector-Vulnerability-Advisory_1001b_V1.0.pdf
- https://www.eaton.com/content/dam/eaton/company/news-insights/cybersecurity/security-bulletins/Eaton-Intelligent-Power-Protector-Vulnerability-Advisory_1001b_V1.0.pdf
Get alerted when CVE-2021-23283 or the next vulnerability affects your stack