What’s Vulnerable › Vulnerabilities
CVE-2021-23288: Security issues in Intelligent Power Protector
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The vulnerability exists due to insufficient validation of input from certain resources by the IPP software. The attacker would need access to the local Subnet and an administrator interaction to compromise the system. This issue affects: Intelligent Power Protector versions prior to 1.69.
Affected products
- Eaton Intelligent Power Protector: before 1.69 — fixed in 1.69
How to fix
Upgrade to a fixed version: Eaton Intelligent Power Protector 1.69. Check the vendor advisory for mitigations.
References
- https://www.eaton.com/content/dam/eaton/company/news-insights/cybersecurity/security-bulletins/Eaton-Intelligent-Power-Protector-Vulnerability-Advisory_1002b_V1.0.pdf
- https://www.eaton.com/content/dam/eaton/company/news-insights/cybersecurity/security-bulletins/Eaton-Intelligent-Power-Protector-Vulnerability-Advisory_1002b_V1.0.pdf
Get alerted when CVE-2021-23288 or the next vulnerability affects your stack