What’s Vulnerable › Vulnerabilities
CVE-2021-23326: Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-01-20 · updated 2026-06-17
- Weakness: CWE-78
Description
This affects the package @graphql-tools/git-loader before 6.2.6. The use of exec and execSync in packages/loaders/git/src/load-git.ts allows arbitrary command injection.
Affected products
- ardatan graphql-tools: before 6.2.6 — fixed in 6.2.6
How to fix
Upgrade to a fixed version: ardatan graphql-tools 6.2.6. Check the vendor advisory for mitigations.
References
- https://advisory.checkmarx.net/advisory/CX-2020-4300
- https://github.com/ardatan/graphql-tools/commit/6a966beee8ca8b2f4adfe93318b96e4a5c501eac
- https://github.com/ardatan/graphql-tools/pull/2470
- https://github.com/ardatan/graphql-tools/releases/tag/%40graphql-tools%2Fgit-loader%406.2.6
- https://snyk.io/vuln/SNYK-JS-GRAPHQLTOOLSGITLOADER-1062543
- https://advisory.checkmarx.net/advisory/CX-2020-4300
- https://github.com/ardatan/graphql-tools/commit/6a966beee8ca8b2f4adfe93318b96e4a5c501eac
- https://github.com/ardatan/graphql-tools/pull/2470
- https://github.com/ardatan/graphql-tools/releases/tag/%40graphql-tools%2Fgit-loader%406.2.6
- https://snyk.io/vuln/SNYK-JS-GRAPHQLTOOLSGITLOADER-1062543
Get alerted when CVE-2021-23326 or the next vulnerability affects your stack