What’s Vulnerable › Vulnerabilities

CVE-2021-23347: Cross-site Scripting (XSS)

Description

The package github.com/argoproj/argo-cd/cmd before 1.7.13, from 1.8.0 and before 1.8.6 are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.

Affected products

How to fix

Upgrade to a fixed version: argoproj argo-cd 1.7.13, 1.8.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-23347 or the next vulnerability affects your stack