What’s Vulnerable › Vulnerabilities
CVE-2021-23392: Regular Expression Denial of Service (ReDoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-08 · updated 2026-06-17
Description
The package locutus before 2.0.15 are vulnerable to Regular Expression Denial of Service (ReDoS) via the gopher_parsedir function.
Affected products
- locutusjs locutus: before 2.0.15 — fixed in 2.0.15
How to fix
Upgrade to a fixed version: locutusjs locutus 2.0.15. Check the vendor advisory for mitigations.
References
- https://github.com/locutusjs/locutus/commit/eb863321990e7e5514aa14f68b8d9978ece9e65e
- https://github.com/locutusjs/locutus/pull/446
- https://snyk.io/vuln/SNYK-JS-LOCUTUS-1090597
- https://github.com/locutusjs/locutus/commit/eb863321990e7e5514aa14f68b8d9978ece9e65e
- https://github.com/locutusjs/locutus/pull/446
- https://snyk.io/vuln/SNYK-JS-LOCUTUS-1090597
Get alerted when CVE-2021-23392 or the next vulnerability affects your stack