What’s Vulnerable › Vulnerabilities
CVE-2021-23400: HTTP Header Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-06-29 · updated 2026-06-17
- Weakness: CWE-74
Description
The package nodemailer before 6.6.1 are vulnerable to HTTP Header Injection if unsanitized user input that may contain newlines and carriage returns is passed into an address object.
Affected products
- nodemailer: before 6.6.1 — fixed in 6.6.1
How to fix
Upgrade to a fixed version: nodemailer 6.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/nodemailer/nodemailer/commit/7e02648cc8cd863f5085bad3cd09087bccf84b9f
- https://github.com/nodemailer/nodemailer/issues/1289
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1314737
- https://snyk.io/vuln/SNYK-JS-NODEMAILER-1296415
- https://github.com/nodemailer/nodemailer/commit/7e02648cc8cd863f5085bad3cd09087bccf84b9f
- https://github.com/nodemailer/nodemailer/issues/1289
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1314737
- https://snyk.io/vuln/SNYK-JS-NODEMAILER-1296415
Get alerted when CVE-2021-23400 or the next vulnerability affects your stack