What’s Vulnerable › Vulnerabilities
CVE-2021-23405: SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-07-09 · updated 2026-06-17
- Weakness: CWE-89
Description
This affects the package pimcore/pimcore before 10.0.7. This issue exists due to the absence of check on the storeId parameter in the method collectionsActionGet and groupsActionGet method within the ClassificationstoreController class.
Affected products
- pimcore/pimcore: before 10.0.7 — fixed in 10.0.7
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/pull/9572
- https://snyk.io/vuln/SNYK-PHP-PIMCOREPIMCORE-1316297
- https://github.com/pimcore/pimcore/pull/9572
- https://snyk.io/vuln/SNYK-PHP-PIMCOREPIMCORE-1316297
Get alerted when CVE-2021-23405 or the next vulnerability affects your stack