What’s Vulnerable › Vulnerabilities
CVE-2021-23406: Remote Code Execution (RCE)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-08-24 · updated 2026-06-17
Description
This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. **NOTE:** The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.
Affected products
- pac-resolver: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: pac-resolver 5.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/TooTallNate/node-degenerator/commit/9d25bb67d957bc2e5425fea7bf7a58b3fc64ff9e
- https://github.com/TooTallNate/node-degenerator/commit/ccc3445354135398b6eb1a04c7d27c13b833f2d5
- https://github.com/TooTallNate/node-pac-resolver/releases/tag/5.0.0
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1568506
- https://snyk.io/vuln/SNYK-JS-PACRESOLVER-1564857
- https://github.com/TooTallNate/node-degenerator/commit/9d25bb67d957bc2e5425fea7bf7a58b3fc64ff9e
- https://github.com/TooTallNate/node-degenerator/commit/ccc3445354135398b6eb1a04c7d27c13b833f2d5
- https://github.com/TooTallNate/node-pac-resolver/releases/tag/5.0.0
- https://snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-1568506
- https://snyk.io/vuln/SNYK-JS-PACRESOLVER-1564857
Get alerted when CVE-2021-23406 or the next vulnerability affects your stack