What’s Vulnerable › Vulnerabilities
CVE-2021-23409: Denial of Service (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-07-21 · updated 2026-06-17
Description
The package github.com/pires/go-proxyproto before 0.6.0 are vulnerable to Denial of Service (DoS) via creating connections without the proxy protocol header.
Affected products
- github.com/pires/go-proxyproto: before 0.6.0 — fixed in 0.6.0
How to fix
Upgrade to a fixed version: github.com/pires/go-proxyproto 0.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/pires/go-proxyproto/issues/65
- https://github.com/pires/go-proxyproto/pull/74
- https://github.com/pires/go-proxyproto/pull/74/commits/cdc63867da24fc609b727231f682670d0d1cd346
- https://github.com/pires/go-proxyproto/releases/tag/v0.6.0
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMPIRESGOPROXYPROTO-1316439
- https://github.com/pires/go-proxyproto/issues/65
- https://github.com/pires/go-proxyproto/pull/74
- https://github.com/pires/go-proxyproto/pull/74/commits/cdc63867da24fc609b727231f682670d0d1cd346
- https://github.com/pires/go-proxyproto/releases/tag/v0.6.0
- https://snyk.io/vuln/SNYK-GOLANG-GITHUBCOMPIRESGOPROXYPROTO-1316439
Get alerted when CVE-2021-23409 or the next vulnerability affects your stack